Symptom
- You have configured Approvals per the "Configure Approvals" help documentation
- The Administrator is concerned that approval requests cannot be sent to a specific team (Org Unit) but are limited to individual users.
- Business concern: If the approval is sent to an individual and they are unavailable, what happens? What can the user do?
- Business wants to understand how the feature works and how to mitigate risks of individual-based assignments.
Environment
- SAP Service Cloud Version 2 1.0
- SAP Sales Cloud Cloud Version 2 1.0
Reproducing the Issue
- Navigate to Settings:
- Go to Settings in SAP Service Cloud.
- Open Business Flow:
- Select Business Flow and then open the Approvals section.
- Configure Approval Flow:
- Set up an approval flow based on an individual role within the Step Details for the Case entity.
- Attempt to Select an Org Unit:
- Try to assign the approval to a team (Org Unit).
- Notice that the system only allows approval assignment to individuals, not based on Org Units.
- Observe the Limitation:
- No options are available to select approval routing based on a team or Org Unit.
Cause
- The approval process in SAP Service Cloud is designed to assign requests based on individual roles, not teams (Org Units).
- The system does not provide a built-in option to assign approvals directly to Org Units, which limits assignment to individuals.
Resolution
- The approval process is based on Roles previously selected by the administrator
- Depending on the Business Flow -> Approval defined settings, a user will only see approvers designated for such tasks from the Involved Parties section
- If an approver is no longer available, the user can remove and select another approver from the list under the Case Involved Parties tab.
- If Business wants to give the option to select multiple approver, the Administrator can use the option:
- Responsibles:
- To include multiple approvers, enable the All Approvals Required switch. However, sequential approval is not supported.
- Direct Approvers:
- You can select specific employees responsible as direct approvers, provided that they possess the corresponding access rights to the task type and business transaction.
- Such approvers also require read access to the relevant business transaction data and write access to the notes of the business transaction.
- You can enable approvers to trigger actions directly from the details of the item to be approved. To do so, from the Approval tab of any related item, make the Actions column visible on the user interface
- The maximum number of direct approvers per approval rule is 10.
- Responsibles:
Keywords
approval workflow, team-based approvals, role-based assignment, Org Unit, SAP Service Cloud, manual approval selection, approval process, custom workflows, reassign approvals, group email, distribution list. , KBA , CEC-CRM-CAS , Case Management for SAP Sales/Service Cloud , Problem
Product
SAP Sales Cloud and SAP Service Cloud Version 2 1.0