SAP Knowledge Base Article - Public

3517463 - Unable to change Token Lifetime and Refresh Token Lifetime of existing OAuth Client in SAP Analytics Cloud (SAC) running on Non-SAP Data Center

Symptom

  • Unable to change Token Lifetime and Refresh Token Lifetime of existing OAuth Client in SAP Analytics Cloud running on Non-SAP Data Center

Environment

  • SAP ANALYTICS CLOUD, Enterprise Edition
  • Non-SAP Data Center (CF)

Reproducing the Issue

  1. Log on to SAC tenant running on Non-SAP Data Center.
  2. Go to System > Administration > App Integration.
  3. Try to Edit any existing OAuth Client.
    => Unable to change Token Lifetime and Refresh Token Lifetime.
    => Only Name is Editable.

Cause

  • It is not supported to update Token Lifetime and Refresh Token Lifetime in current version of SAC.

Resolution

SAC Development is working on one long-term solution to support such change.

Workaround: create an new OAuth client and then migrate your scripts to the new client.

 

See Also

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Keywords

SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics, OAuth, Client, Token, Lifetime, Change, Modify, edit , KBA , LOD-ANA-AUT , SAC Authentication / Login , LOD-ANA-ADM , SAC Administration , Problem

Product

SAP Analytics Cloud 1.0