Symptom
- Unable to change Token Lifetime and Refresh Token Lifetime of existing OAuth Client in SAP Analytics Cloud running on Non-SAP Data Center
Environment
- SAP ANALYTICS CLOUD, Enterprise Edition
- Non-SAP Data Center (CF)
Reproducing the Issue
- Log on to SAC tenant running on Non-SAP Data Center.
- Go to System > Administration > App Integration.
- Try to Edit any existing OAuth Client.
=> Unable to change Token Lifetime and Refresh Token Lifetime.
=> Only Name is Editable.
Cause
- It is not supported to update Token Lifetime and Refresh Token Lifetime in current version of SAC.
Resolution
SAC Development is working on one long-term solution to support such change.
Workaround: create an new OAuth client and then migrate your scripts to the new client.
See Also
- 2569847 - Where can you find SAC user assistance (help) to use, configure, and operate it more effectively?
- Have a question? Ask it here and let our amazing SAP community help! Or reply and share your knowledge!
- 2487011 - What information do I need to provide when opening a case for SAP Analytics Cloud?
- Getting Started with SAP Analytics Cloud Expert Community page
- SAP Analytics Cloud Get More Help and SAP Support
- Need More Help? Contact Support or visit the solution finder today!
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Keywords
SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics, OAuth, Client, Token, Lifetime, Change, Modify, edit , KBA , LOD-ANA-AUT , SAC Authentication / Login , LOD-ANA-ADM , SAC Administration , Problem