Symptom
- Onboarding process is not generated after Onboarding is initiated from Recruiting.
- There is an error log in BPE tile: An error occurred while saving the HRIS data for the user xxxxxx due to the following reason: {"responsePayload":[{"userSysId":"xxxxxx","hrisSaveStatus":[{"elementType":null,"key":null,"statusCode":"ERROR","errorInfo":"Entity:(emailInfo) invalid emailAddress:(xxxx@xxxx.com ) for userSysId: xxxxxx"}]}]}."
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Onboarding is initiated from the RCM
- Onboarding process is not generated
- There is an error log in BPE tile: An error occurred while saving the HRIS data for the user xxxxxx due to the following reason: {"responsePayload":[{"userSysId":"xxxxxx","hrisSaveStatus":[{"elementType":null,"key":null,"statusCode":"ERROR","errorInfo":"Entity:(emailInfo) invalid emailAddress:(xxxx@xxxx.com ) for userSysId: xxxxxx"}]}]}."
Cause
There is an extra space at the end of the email address so it is treated as an invalid value.
Resolution
- Maintain an email address for this candidate's data in RCM. Make sure not to include any extra spaces.
- Go to "Business Process" card in To-do list.
- Find the BPE error and click Restart button.
Keywords
ONB, RCM, BPE, Email, Space, emailInfo, error, invalid , KBA , LOD-SF-OBX-RCM , Initiate onboarding from RCM , Problem
Product
SAP SuccessFactors Onboarding all versions
SAP Knowledge Base Article - Public