Symptom
You are facing the error message below on message monitoring.
{
"code": "inbound-data-connector.133",
"message": "Failed to map the inbound message.",
"details": [
{
"code": "mapping.key.notFound.local.8012",
"message": "Mapping Error at /parentOrganizationalUnitId: Key mapping not found for XXXX, external key $.parentOrganizationalUnitAssignments[].parentCompanyExternalDisplayId"
}
]
}
Environment
- CNS
- SAP Sales and Service Cloud Version 2
Reproducing the Issue
In CNS,
- Go to "Settings"
- Go to "All Settings" tab
- Under Integration tab, go to "Message Monitoring"
- Search for the message ID: XXXXXXXXXXXXXXXXXXXXXXXX
- Check the error message
{
"code": "inbound-data-connector.133",
"message": "Failed to map the inbound message.",
"details": [
{
"code": "mapping.key.notFound.local.8012",
"message": "Mapping Error at /parentOrganizationalUnitId: Key mapping not found for XXXX, external key $.parentOrganizationalUnitAssignments[].parentCompanyExternalDisplayId"
}
]
}
Cause
The Organizational Unit (Company ID) is not maintained under the External ID Mapping.
Resolution
You must ensure that Organizational Unit (Company ID) is maintained under the External ID Mapping.
Keywords
CNS, SAP Sales and Service Cloud Version 2, Organizational Unit (Company ID), External ID Mapping, parentOrganizationalUnitAssignments, parentCompanyExternalDisplayId , KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , Problem