SAP Knowledge Base Article - Public

3517872 - Mapping Error salesOrganizationS4ReplicationMessageIn

Symptom

You are facing the error message below on message monitoring.

{
    "code": "inbound-data-connector.133",
    "message": "Failed to map the inbound message.",
    "details": [
        {
            "code": "mapping.key.notFound.local.8012",
            "message": "Mapping Error at /parentOrganizationalUnitId: Key mapping not found for XXXX, external key $.parentOrganizationalUnitAssignments[].parentCompanyExternalDisplayId"
        }
    ]
}

Environment

  • CNS 
  • SAP Sales and Service Cloud Version 2

Reproducing the Issue

In CNS,

  1. Go to "Settings"
  2. Go to "All Settings" tab
  3. Under Integration tab, go to "Message Monitoring"
  4. Search for the message ID: XXXXXXXXXXXXXXXXXXXXXXXX
  5. Check the error message 

{
    "code": "inbound-data-connector.133",
    "message": "Failed to map the inbound message.",
    "details": [
        {
            "code": "mapping.key.notFound.local.8012",
            "message": "Mapping Error at /parentOrganizationalUnitId: Key mapping not found for XXXX, external key $.parentOrganizationalUnitAssignments[].parentCompanyExternalDisplayId"
        }
    ]
}

Cause

The Organizational Unit (Company ID) is not maintained under the External ID Mapping.

Resolution

You must ensure that Organizational Unit (Company ID) is maintained under the External ID Mapping.

Keywords

CNS, SAP Sales and Service Cloud Version 2, Organizational Unit (Company ID), External ID Mapping, parentOrganizationalUnitAssignments, parentCompanyExternalDisplayId , KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0