Symptom
An editable extension field has been created in the customer demand of a sales order. However, despite the field being marked as editable, it is not possible to make any changes to it.
Environment
SAP Business ByDesign
Reproducing the Issue
- Navigate to the Sales Orders work center.
- Select the Sales Orders view.
- Open a sales order.
- Go to the Document Flow tab.
- Click on Extended View.
- Select the Customer Demand ID.
- Click on View All.
- In the General tab, locate the KUT field (extension field).
Please note that this field, along with other KUT fields on the screen, cannot be updated.
Cause
Since the screen in question is view-only, editing is not permitted.
Resolution
Expected system behavior.
Keywords
Extension field, Unable, Customer Demand, KUT , KBA , AP-RC-UIF-RT-B , ByD HTML5 Client (not for Cloud for Customer) , How To
Product
SAP Business ByDesign all versions