SAP Knowledge Base Article - Public

3517907 - Not Being Able to Add an Editable Extension Field in Customer Demand

Symptom

An editable extension field has been created in the customer demand of a sales order. However, despite the field being marked as editable, it is not possible to make any changes to it.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Navigate to the Sales Orders work center.
  2. Select the Sales Orders view.
  3. Open a sales order.
  4. Go to the Document Flow tab.
  5. Click on Extended View.
  6. Select the Customer Demand ID.
  7. Click on View All.
  8. In the General tab, locate the KUT field (extension field).

Please note that this field, along with other KUT fields on the screen, cannot be updated.

Cause

Since the screen in question is view-only, editing is not permitted.

Resolution

Expected system behavior.

Keywords

Extension field, Unable, Customer Demand, KUT , KBA , AP-RC-UIF-RT-B , ByD HTML5 Client (not for Cloud for Customer) , How To

Product

SAP Business ByDesign all versions