Symptom
The search field in the Service Orders view does not return results when searching for a specific Service/Spare Part ID. No results are displayed even though the Service/Spare Part ID is currently maintained in a Service Order document.
Environment
Reproducing the Issue
- Go to the Service Orders Work Center.
- Go to the Service Orders View.
- Filter for All Orders.
- In the Search field, search for the Service ABC (where ABC represents the Service ID).
No results are displayed in the UI.
Cause
The Service/Spare Part ID is not utilized as a parameter for the search in the Service Orders Processing View. As a result, the system does not return any results when searching for the Service/Spare Part IDs.
The same behavior also occurs for other views such as Sales Quotes, Service Quotes, Sales Orders and Service Confirmations.
Note: If the Service/Spare Part ID is maintained in a Description or External Reference field, then document will be displayed in the UI when the search is performed. This occurs because the Description and External Reference field are utilized as a parameter for the search in the OWL.
Resolution
- Go to the Service Orders Work Center.
- Go to the Service Orders View.
- Filter for All Orders.
- Select the Advance Filter Icon.
- Locate the Item section.
- In the Product ID field, enter the Service ABC.
- Select Go.
- The Service Orders with the Service ABC will be displayed.
The same process can also be applied for other views such as Sales Quotes, Service Quotes, Sales Orders and Service Confirmations.
Keywords
service orders, product ID, spare part ID, search field, no results, advance filter , KBA , AP-SLO-SO , Sales Order , How To