Symptom
When trying to import a Role-Mapped Competencies file, the import fails with an error:
Ooops! The role & Competency Mapping has already been mapped to the ROLE
Environment
- SAP SuccessFactors Job Profile Builder
- SAP SuccessFactors Job Description Manager
Reproducing the Issue
- Log in to SuccessFactors
- Navigate to Admin Center > Job Profile Content Import/Export
- In the Type dropdown, select Role-Mapped Competencies
- Browse for the file > Import
- Receive error
Cause
- Competencies are already mapped to the same Role
- Competencies are duplicated in the import file
Resolution
Competencies are already mapped to the same Role
Option 1: Remove the role-competency mapping from the file
Within the import file, remove the row with the role-competency mapping.
Option 2: Remove the role-competency mapping already in the system
- Use the DELIMIT operator for the competency within the import file by following the steps in 2718919 - Delimit competency mapping via import.
- Remove the mapping via Manage Data:
- Navigate to Admin Center > Manage Data
- In the first Search, select Role
- In the second Search, select the role
- Select Take Action > Make Correction
- Locate the competency and select the trash can icon (delete) > Save
Competencies are duplicated in the import
Within the import file, filter for duplicates in the competencies column and remove one of the duplicates.
See Also
Success Factors, Manage Job Profile Contents Import/Export, Reload jobs, Map Competencies Per Role, Roles Already Mapped, Remove the Mapping, JPB, Role-Mapped Competency, import file, Job Code mapping issue, Competency mapping issues
Keywords
KBA , LOD-SF-TIH-JPB-ADM , Admin Center, Settings, Permissions , LOD-SF-TIH-JDM , Job Description Manager , Problem