Symptom
- Users reported that a new event on the timeline is taking too long to show, sometimes up to 30 seconds.
- This delay is considered too long and the customer expects it to be much faster.
Environment
- SAP Service Cloud Version 2 1.0
- SAP Sales Cloud Version 2 1.0
Reproducing the Issue
- Go to Agent Desktop
- Confirm a BP, and create an interaction via Interaction Log
- The user claims that sometimes it could take from 12 to 30 seconds to see the New Events response shown in the timeline.
Cause
- This is not a bug; the system is functioning as designed.
- The system does not always send timeline updates immediately to prevent unnecessary performance impacts.
- The time it takes to display the New Event on the timeline depends on several factors, including system resources at the time.
- Since users have the option to manually refresh the timeline, the push for automatic updates is not prioritized.
- Factors influencing the delay may include:
- Queue volume: The number of requests being processed.
- Network latency: Speed and quality of the network connection.
- Queue priority for other microservices: Other essential services may be given priority.
- Data Center resource allocation: The system shares resources with other tenants, and prioritization ensures optimal performance and stability across the platform.
Resolution
- Users are encouraged to use the timeline refresh icon to pull the data once it has been saved.
- The system will then query the RestAPI and return the results to the timeline.
Keywords
timeline delay, Agent Desktop, new event delay, system performance, SAP Service Cloud V2, Interaction Log, network latency, queue volume, resource allocation, microservices, refresh timeline, event push , KBA , CEC-CRM-TIM , Timeline for SAP Sales/Service Cloud , Problem
Product
SAP Sales Cloud and SAP Service Cloud Version 2 1.0