Symptom
- Newly hired user cannot access the manual triggered correct form I-9 to complete the data. Unable to fetch form data error is thrown
- I-9 section 1 keeps loading to Newly hired user
- Customer need to correct SSN on I-9 as they provided a dummy SSN only
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
To correct an I9 for the candidate, it can be done via Trigger I9 Flow.
- Login as candidate
- Click on Correct Form I-9 card from Home Page or Todo panel
- Error is thrown - Unable to fetch form data
Cause
- Missing permission
- Message in the developer tools (console):
{
"error" : {
"code" : "ServerErrorException", "message" : {
"lang" : "en-US", "value" : ""
}
}
}
{
"error": {
"code": "ServerErrorException",
"message": {
"lang": "en-US",
"value": ""
}
}
}
Resolution
Even though, the admin can update the SSN through the Employee Profile, it needs to be reflected on the I-9 for the candidate to view the updated SSN and be able to sign it.
- Missing an obscure but critical permission: the View permission to Employment Details MSS. This meant that the Form I-9 was trying to load, but because the user doesn't have the View permission to their own Employment Details, the Form I-9 (which includes Employment Details) was not loading.
- Note that the SSN will still need to be corrected at the Employee Profile level for this to work correctly.
See Also
Keywords
Onboarding, obx, ssn, correct ssn, trigger I-9 flow, manual trigger, correct form I-9, unable to fetch form data, hired, employee profile, Request failed with status code 500: GET /odata/v2/restricted/getComplianceFormMetadata,ComplianceFormMetadataResponse, ERROR [ComplianceToECODataApiQueryBuilder], OData call failed to get any result for query :, compliance , KBA , LOD-SF-OBX-FRM , Compliance 2.0 Country Forms (except i9&EV) , Problem