SAP Knowledge Base Article - Public

3519122 - CPQ Products List view Error

Symptom

While applying a filter on the product list page to retrieve specific data, you might encounter the error message: "A server-specific error occurred!"

Environment

SAP SALES CLOUD CPQ

Reproducing the Issue

  1. Go to Setup
  2. Product catalog
  3. Products
  4. Apply filter
  5. Check for relevant product or part number with more than 500 records
  6. Observe the error pop-up message.

Cause

When replicating products, there is a possibility that the table becomes locked due to updates or inserts made through the replication process.

This often results in timeouts when attempting to read data from the products page.

Resolution

Please reach out to CPQ support team for further assistance.

Keywords

Server specific error occurred!, product page, products view, products, Server specific error occurred , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Problem

Product

SAP CPQ all versions