Symptom
While applying a filter on the product list page to retrieve specific data, you might encounter the error message: "A server-specific error occurred!"
Environment
SAP SALES CLOUD CPQ
Reproducing the Issue
- Go to Setup
- Product catalog
- Products
- Apply filter
- Check for relevant product or part number with more than 500 records
- Observe the error pop-up message.
Cause
When replicating products, there is a possibility that the table becomes locked due to updates or inserts made through the replication process.
This often results in timeouts when attempting to read data from the products page.
Resolution
Please reach out to CPQ support team for further assistance.
Keywords
Server specific error occurred!, product page, products view, products, Server specific error occurred , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Problem
Product
SAP CPQ all versions
SAP Knowledge Base Article - Public