Symptom
You are in Business Partner contact and you receive an error message Cannot lock alt. key ZACCOUNTIDXXXXXXXXXXXXXXXXX with value 123456789; instance is locked by user ABC(ABC) Action could not be executed
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Business Partner
- Search Business Partner ID "123456789" and Open
- Error: Cannot lock alt. key Cannot lock alt. key ZACCOUNTIDXXXXXXXXXXXXXXXXX with value 123456789; instance is locked by user ABC(ABC)
Action could not be executed
Cause
Cannot lock alt. key ZACCOUNTIDXXXXXXXXXXXXXXXXX with value 123456789; instance is locked by user ABC(ABC) Action could not be executed. If two Users are in the same Business Partner at the same time, they will get a warning message so they cannot make changes at the same time.
Resolution
This is expected System Behaviour. The system is designed in this way to prevent inconsistencies.
Keywords
Business Partner, Contact, Instance is Locked by User, Action could not be Executed , KBA , LOD-LE-BP-BP , Business Partner , Problem
SAP Knowledge Base Article - Public