Symptom
You are trying to assign a certificate for business user for API consumption(to use certificate based authentication) in the Sales & Service Cloud v2 system and you get the error "Certificate Email is different from the User Email"
Environment
SAP Sales Cloud Version 2
SAP Service Cloud Version 2
Reproducing the Issue
- Go to Settings
- Under "Users and Control" , open "Users"
- Choose a Business User you have created for API Consumption
- Click on the USER ID
- Click "Manage Certificates" under User details section
- Click on "Browse Files" and select the certificate to upload from your system
- error "Certificate Email is different from the User Email" occurs
Cause
Only User Specific certificates can be uploaded to Business User. We do the validation based on the certificate parameter "Subject Alternative Name" whether it matches to the email mentioned on the employee record(business user) while assigning the certificate. Only then you can use certificate based authentication for business users.
Resolution
This means using the email address of the employee assigned in business user - you have to get a certificate issued by one of the authorized Certification Authorities approved by SAP. Check the KBA available in "See Also" section for the list of authorized certification authorities.
See Also
SAP Global Trust List ;
Need for Business User While Configuring Code Replication Iflows From SAP S4HANA To SAP Sales & Service Cloud V2 ;
APIs in SAP Sales Cloud and SAP Service Cloud Version 2
Keywords
"Certificate based authentication for Business User" "Certificate based authentication in Sales & Service Cloud v2" , KBA , CEC-CRM-IAM , Identity and Access Management for SAP Sales/Service Cloud , CEC-CRM-DC , Data Connector for SAP Sales/Service Cloud , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , Problem