Symptom
You are getting the error message "The new app variant was saved, but could not be assigned to the catalog. Please send the following technical information to your content administrator: App variant ID: XXXXX Error: Connection timeout." when saving an App Variant.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Open the Standard Application
- Click on Adapt UI
- Click on App Variants icon
- Click on "Save as"
- Proceed with the App Variant creation and once it's created, the timeout occurs
Cause
The issue arises due to a timeout occurring during a long-running request.
Resolution
The app variant has been created anyways and you can manually assign it in the customer catalogue extension app.
- Go to the Custom Catalog Extension app
- Locate the newly created app variant
- Assign the catalog
- Publish it
-
Keywords
Custom CDS Views, App Variant, Catalog Assignment, Connection Timeout, Manual Assignment, Long-Running Request, Catalog Extension App. , KBA , CA-UI5-ABA-AIDX , UI5 App Infrastr.: App Index,Descriptor & Variants , Problem