SAP Knowledge Base Article - Public

3519582 - Timeout Error during App Variant Assignment

Symptom

You are getting the error message "The new app variant was saved, but could not be assigned to the catalog. Please send the following technical information to your content administrator: App variant ID: XXXXX Error: Connection timeout." when saving an App Variant.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Open the Standard Application
  2. Click on Adapt UI
  3. Click on App Variants icon
  4. Click on "Save as"
  5. Proceed with the App Variant creation and once it's created, the timeout occurs

Cause

The issue arises due to a timeout occurring during a long-running request. 

The app variant has already been created and is available in the Custom Catalog extension app. Now the system tries to identify the catalogs to which the app should be assigned automatically. To do this it evaluates all roles of the user whether they contain the original app and assigns them to the custom catalog extension.
In the case the user has a lot of catalogs the process might take too long and a timeout occurs that stops the process.

Resolution

The app variant has been created anyways and you can manually assign it in the customer catalogue extension app.

You can use the following workaround:
  1. Go to the Custom Catalog Extension app
  2. Locate the newly created app variant
  3. Assign the catalog
  4. Publish it

    Keywords

    Custom CDS Views, App Variant, Catalog Assignment, Connection Timeout, Manual Assignment, Long-Running Request, Catalog Extension App. , KBA , CA-UI5-ABA-AIDX , UI5 App Infrastr.: App Index,Descriptor & Variants , Problem

    Product

    SAP S/4HANA Cloud Public Edition all versions