Symptom
Custom workflow email notification not triggering to CC roles after manually terminating a Higher Duty Assignment
Environment
SAP SuccessFactors Employee Central - Higher Duty Assignment
Reproducing the Issue
- Navigate to the profile of a User with Higher Duty Assignment.
- Click on Actions -> Manage Higher Duty/Temporary Assignment -> Click on the Edit Button and mention the End Date -> Click on Save.
- The system triggered the rule assigned as onSave in Job Info and the workflow. This workflow has no approver, only CC role.
- The custom workflow email notification template assigned to the CC role is not triggered.
Cause
Engineering has confirmed that triggering workflow notifications for Higher Duty Assignment without approver is currently not supported as part of Higher Duties.
Resolution
This will be delivered as a future enhancement.
See Also
Keywords
HD, HDA, Higher Duty, Assignment, Workflow Higher duty, workflow, HD WFL, HD Workflow, Higher duty notification. , KBA , LOD-SF-EC-HDP , Higher Duties & Public Sector , Product Enhancement
Product
SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Core all versions