SAP Knowledge Base Article - Public

3520023 - Customizations in the Ticket Timeline

Symptom

You would like to customise the Timeline screen (COD_Interaction_Timeline_EC) on a ticket but that does not seem possible. In Adaptation, very few options are visible.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the work center Service, view Tickets.
  2. Open any ticket
  3. Go to the Timeline tab.
  4. Go into the adaptation mode.
  5. Edit any of the sections.
  6. It does not seem possible to add custom sections, fields, rules etc. Nothing is offered.

Cause

Extensibility is unfortunately not supported for the timeline EC.

Resolution

The options via PDI are limited because of this. You should be able to remove elements such as buttons if you do not wish to see them, create mashups, and some custom actions could be developed. You will see the options when you check the EC in the studio. But unfortunately the technical specifics of this screen prevent major customization.

Keywords

timeline, adaptation, PDI, SDK, customization, not possible to edit, ticket , KBA , LOD-CRM-SRP-INT , Ticket Interactions , Product Enhancement

Product

SAP Cloud for Customer core applications 2408