SAP Knowledge Base Article - Public

3520112 - Dashboard does not appear for users

Symptom

You want to show the standard dashboard, e.g. "Service Overview" via the work center Analysis to a specific user.

Environment

SAP Business ByDesign

Reproducing the Issue

1. Go to Analytics work center.

2. Search for Service overview.

3. You cannot see it.

Cause

This is expected behavior.

A user will be able to see a dashboard in Analytics -> Dashboards if they have authorizations for at least one of the reports in that dashboard. Example: User XYZ has access to only 3 reports, none of which are in any of the dashboards, hence he cannot see the dashboard.

Ideally, a user should have access to all the reports of a dashboard to be able to use the dashboard properly. 

 

Resolution

To correct this, the system admin has to assign all the related dashboard reports to at least one of the Work Center Views of this user.

Steps:

  1. Go to Business analytics work center.
  2. Go to Design report.
  3. Search for the report name or id.
  4. Select the row containing the report name.
  5. Click in Assign button.
  6. Set at least one assignment equals to user's assignment.

Keywords

Dashboard; not visible; visible; report; user; , KBA , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , Problem

Product

SAP Business ByDesign all versions