Symptom
Email template 'Compliance Document Signature Task Completion Trigger' is being sent multiple times (twice or three times) for a candidate upon completion of compliance tasks in Onboarding.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Complete a Compliance Document Signature Task in SAP SuccessFactors Onboarding.
- Observe that multiple email notifications are triggered for the compliance tasks completion.
Cause
It happens because the email notification trigger is configured to be sent each time a candidate completes an activity related to compliance tasks.
Resolution
"Compliance Document Signature Task Completion Trigger" notification indicates the successful submission of signed documents and is sent upon the completion of any compliance document signing task.
Since these notifications are triggered individually upon the completion of each relevant task, receiving multiple emails is expected behavior rather than a system issue. However, the customer has the option to disable the notifications if they are considered unnecessary.
Scenario as example: Customer has a notification under "Compliance Document Signature Task Completion" trigger, and notifications are being sent two or three times, as candidates complete each step of their compliance task.
However, even though they already received it multiple times, there are other emails configured for similar topics. One example is the "Bring Original Documents for Employment Eligibility Verification", which is reserved for I9 task completion, in this case this additional email will also be triggered.
Customer needs to consult their Implementation Partner, in order to get the best guidelines on how to configure their system, one which addresses their own business requirements.
Keywords
Compliance, Document, Signature, Task, Duplicate, Notifications, Email, Templates, send, sent, more, twice, times, multiple, Onboarding, OBX, 2.0 , KBA , LOD-SF-OBX-EML , Notifications , Problem