Symptom
An error message “Business Partner xxxx does not exist in role xxxx ” is displayed while assigning a relationship category to the business partner.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Go to Manage Business Partner Master Data app
- Open the business partner
- Go to relationship tab
- Add a role & assign the business partner
- Choose save
- An error message 'Business partner xxx does not exist in role xxxx' is displayed.
Cause
In the relationship category definition, a role category is specified. If the BP is not assigned to the appropriate role within this category, an error occurs.
Resolution
TBZ9 is the only configuration activity to maintain relationship categories. At present, there is no configuration option available for the view V_TBZ9.
Hence, no configuration is available for the cloud system.
See Also
Keywords
Business partner xxx does not exist in role xxxx , relationship category, Has the Responsible Partner Contact. , KBA , LO-MD-BP-2CL , Business Partners for Public Cloud , Problem