Symptom
- The customer needs to create a no-reply email channel for outbound communication only.
- During the email channel creation process, a 2FA (Two-Factor Authentication) is required to complete activation.
- The no-reply channel cannot be activated because there is no inbox on the customer’s server to receive inbound emails and complete the 2FA process.
Environment
- SAP Service Cloud Version 2.1.0
- SAP Sales Cloud Version 2.1.0
Reproducing the Issue
- Go to Settings -> Email Channels
- Create an E-mail Channel
- Activate
- user will be required to complete the 2FA verification process
- such process which involves receiving a notification to the defined email address
- since the address either does not have an inbox or incoming messages are rejected, the process cannot be completed
Cause
- The system is working as designed
- The 2FA requirement for email channel activation is blocking the process since the system expects a valid inbox to receive the authentication code, which is not available for no-reply channels.
- Two-Factor Authentication (2FA) is a mandatory security requirement and cannot be bypassed.
Resolution
- Temporarily set up an inbox on the customer's email server to receive the 2FA code during channel creation.
- Once the channel is activated, disable the inbox for inbound communications, turning it into a no-reply channel.
- If setting up a temporary inbox is not possible, consider submitting a request for a feature enhancement via the SAP Customer Influence Program: Sales and Service Cloud V2 Influence.
Keywords
no-reply email channel, outbound communication, 2FA requirement, email channel activation, workaround, SAP Service Cloud, SAP Sales Cloud, feature request, email server , KBA , CEC-CRM-CHN , Channels for SAP Sales/Service Cloud , Problem
Product
SAP Sales Cloud and SAP Service Cloud Version 2 1.0