Symptom
You maintain the Sate of the Account in the Address, however the Sate is not displayed in the Address - Row field. You notice that this only happens to certain Accounts.
Environment
Cloud for Customer
Reproducing the Issue
- Go to the Customers work center
- Go to the Accounts work center view
- Create an Account
- Maintain the State in the Address (e.g. 62 - Pas-de-Calais for France)
Result: The State is not displayed.
Cause
The format of the Address is decided in the Business Configuration => Countries/Regions => Postal Attributes => Address Formatting Routine.
Depending on the formatting, a State is displayed in Address or not.
Examples
Country = France
001 - European standard address is maintained in Address Formatting Routine => State is not displayed.
Country = United Sates
004 - USA is maintained in Address Formatting Routine => State Code is not displayed.
Country = Japan
113 - Japan (new) is maintained in Address Formatting Routine => State name is displayed.
Resolution
This is an expected system behavior.
Keywords
address, state, missing, row, account, customer, country, region , KBA , LOD-CRM-ACC , Account , Problem