SAP Knowledge Base Article - Public

3521050 - Manage Business Partner Master Data - Changes to field "IBAN valid from" are not saved

Symptom

Changes to field 'IBAN valid from' are not saved when using Fiori apps Manage Business Partner Master Data, Manage Customer Master Data and Manage Supplier Master Data.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Go to the Manage Business Partner Master Data app.
  2. Open the Business Partner.
  3. Navigate to the "Bank Accounts" tab.
  4. Select the bank account.
  5. Modify the IBAN Valid From Date and save it.
  6. The changes are not saved.

Cause

This is the standard system behavior.

Resolution

  • If the IBAN was used in any other BP then the date would remain as 31.12.9999.
  • Follow below steps to update the validity date via the following:
      1. App 'Maintain Business Partner' 
      2. Choose supplier.
      3. Go to the Payment.
      4. Instructions tab.
      5. Switch to the edit mode.
      6. Click on the button IBAN, then on the button 'Change IBAN'.
      7. Choose the option 'Change IBAN for Existing Bank Details'. The fields IBAN and 'Valid From' will then become editable.
      8. Save the changes.

See Also

  • KBA 3586362 - Issues with Saving Changes to IBAN Valid From Field in SAP S/4HANA Cloud Public Edition - SAP for Me.
  • KBA 3401571 - Business Partners IBAN shows "valid from" 31.12.9999 in SAP S/4HANA Cloud - SAP for Me.

Keywords

confirmation, IBAN, business partner, valid from, iban valid from, 9999 , KBA , LO-MD-BP-2CL , Business Partners for Public Cloud , Problem

Product

SAP S/4HANA Cloud Public Edition all versions