Symptom
Changes to field 'IBAN valid from' are not saved when using Fiori apps Manage Business Partner Master Data, Manage Customer Master Data and Manage Supplier Master Data.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Go to the Manage Business Partner Master Data app.
- Open the Business Partner.
- Navigate to the "Bank Accounts" tab.
- Select the bank account.
- Modify the IBAN Valid From Date and save it.
- The changes are not saved.
Cause
This is the standard system behavior.
Resolution
- If the IBAN was used in any other BP then the date would remain as 31.12.9999.
- Follow below steps to update the validity date via the following:
-
-
- App 'Maintain Business Partner'
- Choose supplier.
- Go to the Payment.
- Instructions tab.
- Switch to the edit mode.
- Click on the button IBAN, then on the button 'Change IBAN'.
- Choose the option 'Change IBAN for Existing Bank Details'. The fields IBAN and 'Valid From' will then become editable.
- Save the changes.
-
See Also
Keywords
confirmation, IBAN, business partner, valid from, iban valid from, 9999 , KBA , LO-MD-BP-2CL , Business Partners for Public Cloud , Problem
Product
SAP S/4HANA Cloud Public Edition all versions
SAP Knowledge Base Article - Public