Symptom
A filter was created to users with a specific page layout and it was noticed the filter is not working as expected.
For example, users have page layout "ABC" and when accessing Products facet inside Sales Quotes, clicking on Add products and searching for one, the query displays results for all products, not only for the ones available in the filter "XYZ" created.
Environment
SAP Cloud for Customer
Reproducing the Issue
Steps can change, this is just an example scenario:
- Go to Sales > Sales Quotes.
- Open any.
- Go to Products facet.
- Click on Add.
- Enter a letter, for example, "L".
- See the results is not showing as expected.
- Now click on help button.
- See it is already filtered by "XYZ".
Cause
As there is no default query set, when searching from product field directly the system checks with "All" query even though is it not present.
When searching from OVS using custom query (in this example "XYZ") the result is different.
Resolution
Please make the custom query/filter as default query and search:
- Go to the Products section value help.
- Click on advanced search.
- Click on 'Organize queries'.
- Set "XYZ" as default and save.
The steps above can change according to the business scenario, but the 'Organize queries' is set in the help button regardless the object search.
Keywords
Filtering, filters, queries , KBA , AP-RC-UIF , C4C UI Framework , LOD-LE-CQP-CO , Lean Sales Orders , LOD-CRM-OPP , Opportunity Management , LOD-LE-CQP , Customer Quote Processing , Problem