Symptom
The standard C4C-CPQ integration is not functioning for certain users.
Error: "login.microsoftonline.com refused to connect".
Environment
SAP SALES CLOUD CPQ
Reproducing the Issue
- Login to C4C
- Go to Sales quotes
- Select Sales quote - the error message occurs "login.microsoftonline.com refused to connect".
Cause
You need to fix the SSO issue on the IdP side for the users who are facing the issue.
Resolution
- C4C is opening CPQ in an iFrame using SSO login.
When a quote is accessed from C4C, CPQ creates an SSO request sent to Microsoft IdP, which denies access.
This issue is not related to CPQ but to the Microsoft IdP configuration for iFrame settings, which is blocking the connection.
Configuration for iFrame on the Microsoft IdP in use should be reviewed. -
As starting point please refer: https://learn.microsoft.com/en-us/answers/questions/957121/login-microsoftonline-com-refused-to-connect-on-xf ".
Keywords
C4C-CPQ integration, refuse to connect, Microsoft online, IdP, SSO, error, sales quote, CPQ quote , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Problem
Product
SAP Cloud for Customer core applications 2408