Symptom
When trying to search for, for example, products and entering letter 'A' in Products field inside Sales Quote, system suggests incorrect options as none of the products starts with 'A'. The same behavior is faced with any other letter.
Environment
SAP Cloud for Customer
Reproducing the Issue
Steps can change according to the scenario. For example:
- Go to Sales > Sales Quotes.
- Open a Quote.
- Go to Products facet.
- Click on 'Add' in Products section.
- On Product field, enter just letter 'a' - see no suggestion of products starting with 'a' is shown.
- If you click on value help and enter 'a' in the search again, same results found
- But if you scroll to next pages you will see there are actually Products starting with 'A'.
Cause
When searching with the basic search in products with "A", the Column ID, Description (name of product) and life cycle status code are being searched at the backend. This is how the system is designed.
When searching with *A*, if any column has letter 'A' in it, it will return the product. Also, as life cycle status code of the product is involved in the search columns as mentioned, 'A' would be a part of "Active", hence the active products will be returned.
Resolution
This is the expected system behavior.
If the feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available.
Keywords
Letters, B, C, D, E, F, G, H, I, J, K, L, M, N, O, P, Q, R, S, T, U, V, W, X, Y, Z , KBA , LOD-LE-CQP , Customer Quote Processing , Problem