Symptom
The 'Assign To Me' action button in ticket screen does not work when mandatory field is empty.
Error message: 'Cannot save, as field 'XXX' is specified as mandatory by the administrator.'
In ticket OWL, button works fine without any error in the same condition.
Same behavior can be observed on other assignment functions such as 'Assign To Agent' and 'Assign to Team'.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Log in to system.
- Go to the Service - Ticket.
- Find a ticket with an empty mandatory field and open it.
- Go to Actions, select 'Assign to me'.
- Error message pops up 'Cannot save, as field 'Account' is specified as mandatory by the administrator.'
- Go to Service - Ticket OWL.
- Select the same ticket.
- Click on More - Assign to Me/Team/Agent.
- Save succeeded.
Cause
Ticket OWL and ticket screen have different functionalities, Some validations will not work in ticket OWL
In the ticket screen, assignment function requires all mandatory fields to be filled in the ticket.
Resolution
This is the standard behavior of the system.
If the feature/functionality is needed as a matter of urgency, please refer to KBA 3475641 - Functionality Currently not Available (C4C).
See Also
Keywords
SAP Cloud for Customer, Ticket, Assign To Me, Mandatory Fields, Error Message , KBA , LOD-CRM-SRP , Service Request Processing , How To