Symptom
The "Reason for Rejection" in the sub line is not removed automatically when from the parent line
Environment
Cloud for Customer
Reproducing the Issue
- Open a Sales Order
- There is a parent line in the product tab with sublines
- Change the Reason for Rejection on the parent line
- The Reason for Rejection is not removed from the subline
Cause
This is a standard system behaviour.
Resolution
The reason for this is due to the hierarchical structure of sales orders. The parent line item represents the main product or service being sold, while the sub-line items represent additional components or services related to the main product.
When a reason for rejection is applied to a parent line item, it is assumed that this rejection applies to all associated sub-line items as well. However, if a reason for rejection is applied to a sub-line item, it does not necessarily mean that the parent line item or other sub-line items are also rejected.
Therefore, when a reason for rejection is deleted from a parent line item, it is not automatically deleted from the sub-line items. This is to ensure that any specific issues or rejections related to individual sub-line items are not overlooked or ignored.
Keywords
Parent Line, Sub Line, Reason for Rejection, Sales Orders, Products , KBA , LOD-LE-CQP-CO , Lean Sales Orders , How To