SAP Knowledge Base Article - Public

3522174 - Customer invoice with Down payment request not generating the Journal entry due to Process communication error - 'For more details, see the dump in the "Application Info" section'

Symptom

No journal entry is getting created for the Customer invoices, when you checked the document flow of that Customer invoice 'ABC' you can be able to see the Process Communication error icon in the Customer invoice 'ABC'.

 
'ABC' - refers to the Customer Invoice ID.

Environment

SAP Business ByDesign 

Reproducing the Issue

  1. Go to the Customer Invoicing work center.
  2. Go to the Invoice Documents sub view.
  3. Open the relevant Customer Invoice 'ABC'.
  4. Navigate to the Document Flow
  5. You can see that no Journal Entry was created for this Customer Invoice 'ABC'.
  6. Along with that you can be able to see the Process communication error icon.
  7. Go to the Application and User Management work center.
  8. Go to the Process Communication Errors sub view.
  9. Search with the Sending document as Customer Invoice.
  10. You can see the Main error as 'For more details, see the dump in the "Application Info" section' 

Cause

One of the reasons for the dump might be that Customer invoice 'ABC' is having Down-Payment-Request which is connected to it doesn't have G/L account posting block settings as allowed.

  1. Go to the Customer Invoicing work center.
  2. Go to the Invoice documents sub view.
  3. Search for the Customer invoice 'ABC'.
  4. Navigate to the Pricing tab.
  5. Go to the Payment details sub tab.
  6. Here you can be able to see that the down payment received is considering the G/L account: 'DEF'


But this G/L-Account 'DEF' has its Posting-Block attribute is set to "No Postings Allowed", follow the below steps to check that

  1. Go to the Business Configuration work center.
  2. Go to the Overview.
  3. Search for the Chart of Accounts activity.
  4. Go to the Edit Chart of accounts and select the relevant Chart of accounts ID.
  5. Below under details, you can be able to see all the G/L accounts assigned to this Chart of accounts ID.
  6. Search for the G/L account: 'DEF', you can see that Posting-Block attribute is set to "No Postings Allowed".
  7. Due to this reason, postings i.e., Journal Entry can't be posted to the accounting side.

Resolution

For the involved G/L-Account setting you have to set the Posting Block attribute to "All postings allowed" for the creation of Journal entry.

  1. Go to the Business Configuration work center.
  2. Go to the Overview.
  3. Search for the Chart of Accounts activity.
  4. Go to the Edit Chart of accounts and select the relevant Chart of accounts ID.
  5. Below under details, you can be able to see all the G/L accounts assigned to this Chart of accounts ID.
  6. Search for the G/L account: 'DEF' and set the Posting-Block attribute to "All Postings Allowed"
  7. It should now create the journal entry for the Customer Invoice 'ABC'.

If it still not created, you have to create the case to SAP Technical Support to restart the failed XI message from the backend. Once the failed XI message delivered successfully from the backend then Customer Invoice will be posted with the Journal entry.

Keywords

Process Communication error, Customer Invoice, Customer Invoice, G/L account, Down Payment Request, Posting-Block, Chart of Accounts. , KBA , AP-ACC-AN , Accounting Notification , Problem

Product

SAP Business ByDesign 2408