SAP Knowledge Base Article - Public

3522198 - DocuSign Envelope Not Auto Filling In SAP C4C Quote

Symptom

When creating a DocuSign envelope for a sales quote in SAP Sales Cloud (C4C), the values are not getting autopopulated.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Sales work center.
  2. Go to the Sales Quotes work view.
  3. Open the affected Quote. 
  4. Navigate to DocuSign tab.
  5. Click on New Envelope button.

Result: All the fields will be blank. The information in C4C is not carrying over to the DocuSign when you try to send it. Typically, you can add the missing info like the Subject, message, or create the recipient.

Cause

The X.509 BTP certificate has been expired, this can be checked on:

  1. Go to the Administration work center
  2. Go to the General Tasks work view
  3. Configure OAuth-2.0-Identity-Provider
  4. Select Provider with common name "cfapps.xxxx.hana.ondemand.com/XXXXX-XXXXX-XXXX-XXXXX-XXXXX"
  5. You'll see that the certificate is expired.

Resolution

Renew and import in C4C the BTP X.509 certificate as per the documentation: https://help.sap.com/docs/connectivity/sap-btp-connectivity-cf/set-up-trust-between-systems#renew-a-certificate


 

See Also

https://help.sap.com/docs/SAP_CLOUD_FOR_CUSTOMER/0fadcb5e34744853a7f2d8c2dcb5ad8f/94e44a2df8d141a7a06138e1c86aecc8.html

Keywords

DOCUSIGN 502 C4C BTP TRUST OAUTH CLIENT CERTIFICATE , KBA , LOD-C4C-NET , Network Connectivity and Certificates , XX-PART-DSN , SAP Signature Management by DocuSign , LOD-LE-CQP , Customer Quote Processing , How To

Product

SAP Cloud for Customer core applications all versions