SAP Knowledge Base Article - Public

3522733 - Unable to Process E-Verify Cases due to "Duplicate Case" Error - Onboarding 1.0

Symptom

    Error " Duplicate Case: We are having trouble retrieving the list of Duplicate Cases from the Department of Homeland Security's (DHS) E-Verify service. The DHS E-Verify service may be unavailable. You can learn more about how to proceed by reviewing this Knowledge Based Article when submitting an E-Verify case for new hires.

    "Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental." 

    Environment

    SAP SuccessFactors Onboarding 1.0

    Reproducing the Issue

    1. Go to onboarding and try proceed with submitting an E-Verify case for new hires.
    2. The following message error will appear:

    Duplicate Case

    We are having trouble retrieving the list of Duplicate Cases from the Department of Homeland Security's (DHS) E-Verify service. The DHS E-Verify service may be unavailable. You can learn more about how to proceed by reviewing this Knowledge Based Article. 

    Cause

    • Cause 1: Connection issue with DHS, causing you not being able to correctly submit data to DHS.
    • Cause 2: Incorrect Client Company ID provided in Super Admin > E-Verify Options
    • Cause 3: EverifyClientID in Onboarding Application does not match company ID in DHS record.

    Resolution

    Cause 1:

    The error message sent by you means that DHS (Department of Homeland Security) E-verify Service is experiencing intermittent system outages and not able to respond to requests from Onboarding application.

    Please understand that SAP can’t control how E-verify service is working, because it’s government service.

    As DHS is not controlled by SAP, for the next steps, you would need to wait for the DHS to comes back to normal before performing the operation. 

    Please keep an eye on this feature and try refreshing it at different times later.

    Cause 2:

    1. Go to Super Admin.
    2. Navigate to E-Verify Options.
    3. Update to the same Client Company ID corresponding from the DHS system.
      • If you don't know what would be the Client Company ID, please submit a case to SAP SuccessFactors Cloud Support via SAP for Me to request for the SAP Product Support to confirm the Client Company ID used in DHS systems.
    4. Save the changes.
    5. Confirm that it is now possible to submit the e-verify case without receiving the error regarding a duplicated case or the DHS E-Verify service being unavailable.

    Cause 3:

    1. Log into SuccessFactors and in module picker, select to Onboarding 1.0
    2. In the drop-down, select Reference Files > Corporate Structure.
    3. Search for company in Client ID field in company corporate structure.
    4. Double-click on the company and scroll down to EVerifyClientID 
    5. Ensure that this matches with company ID in DHS. 

    See Also

    • 3409853: Cannot close E-verify Duplicate Case - Onboarding
    • 2160509: How to Process an Activity with "Duplicate Case" Status in E-Verify [Process] - Onboarding 1.0
    • 2278277: How to Create an E-Verify Process [Process] - Onboarding 1.0

    Keywords

    E-Verify, Onboarding, duplicate, case, DHS, Client, Company, ID, SuperAdmin, Super, Admin, case, number, unavailable , KBA , LOD-SF-OBD-EVF , e-Verify , Problem

    Product

    SAP SuccessFactors Onboarding all versions