SAP Knowledge Base Article - Public

3522863 - CC Role notification from workflow only received by the first recipient - Employee Central

Symptom

  • Workflows without approvers (only CC Roles), it was observed that only the first recipient defined in the workflow as CC receives the email notification.
  • This issue persists regardless of the order in which the CC entries are defined.
  • The expectation is that all recipients defined in the workflow as CC should receive a mail notification.

Environment

  • SAP SuccessFactors Employee Central
  • SAP SuccessFactors HCM

Reproducing the Issue

  1. Make sue you have at least 2 users with same Display Name into User Data File (UDF)
  2. Configure a business rule with workflow without approvers, only CC Roles, by inserting users above
  3. Make required changes to trigger workflow
  4. Notification is only sent to first recipient

Cause

The issue was caused by the system checking the display names of the users instead of the person IDs.

Resolution

  1. Identify the users with the same display names in the system.
  2. Rename the users to ensure unique display names for each user.
  3. Test the workflow again to confirm that all recipients defined in the workflow as CC Role are receiving the email notification.

See Also

Refer to the following KBAs for additional information:

Additional Guide:

Keywords

Workflow, CC notification, first recipient, email notification, same display name, unique display name, person ID, rename users, all recipients, employee central, employee profile, successfactors, SF, EC, EP , KBA , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , LOD-SF-EC-ALR , Alerts & Notifications (saveAlert - EC Core only) , LOD-SF-EC-WFL-CUS , Custom Workflow Notifications , LOD-SF-EC-WFL-RUT , Workflow Routing, Dynamic Roles & Groups , LOD-SF-EC-WFL-TOL , Admin Tools, Pending Req, Admin Alerts, Check Tool , How To

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions