SAP Knowledge Base Article - Public

3523077 - Appointments without valid attendees cannot be synced from Outlook to C4C using Server Side Integration

Symptom

Cannot sync appointments with an attendee that is not a valid contact or individual customer inside C4C using server side integration

Environment

SAP Cloud for Customer

Reproducing the Issue

  • Create an appointment in Outlook
  • Add an attendee into the appointment that is not a valid contact or individual customer inside C4C
  • Try and force or auto - sync this appointment to your C4C system.
  • The appointment does not get replicated to C4C

Cause

This is the expected system behavior

Resolution

The server side sync engine will only sync appointments to C4C if it contains a valid attendee. However, this can be bypassed by enabling the setting "Save even if there are no Contacts or Individual Customers to link".

To enable this

  • Navigate to groupware settings --> desired profile
  • Open sync settings
  • Under Calendar sync options you will find the setting "Save even if there are no Contacts or Individual Customers to link "

Keywords

Appointments, auto sync, attendees, cannot, syncing, Outlook, C4C, server side integration, Groupware , KBA , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , Problem

Product

SAP Cloud for Customer core applications all versions