SAP Knowledge Base Article - Public

3523343 - No Option To Change The Contacts Relationship When Creating An Appointment/Visit Using Outlook App On iPad (Server Side Integration)

Symptom

When creating a new Visit on Outlook app calendar, there is not option to select the contact relationship as the server side addon side panel is not available.
So, all new appointments are created to the main relationship.

Environment

SAP Cloud for Customer

Reproducing the Issue

1. Open the C4C app on iPad.
2. Go to Customers then Contacts work center.
3. Search for "123" contact.
4. Open it and go to Relationships facet.
5. There are two relationships: ABC and DEF.
6. Go to Outlook app.
7. Create a new appointment. (Ex.: Test1)
8. Search for "123" contact.
9. Categorize as Visit and SAP Cloud for Customer and save.
10. Return to C4C app and force sync.
11. Go to appointments work center.
12. Open the appointment you have created "Test1".
13. Check the Account field on header "ABC".

Cause

The Outlook app for iPad or mobile, no add-ons can be opened in the Outlook mobile calendar, due to a limitation from Microsoft.
Microsoft has only enabled add-ons for use in Outlook mobile emails, where you can open an add-on in some email and schedule a visit.

Resolution

However, opening Outlook in OWA, you can access the add-on in the calendar when adding an appointment, and you can select the necessary relationship.

To do this, follow these steps:

1. Open Outlook OWA on your iPad or mobile.
2. Go to the calendar.
3. Click on Create a new appointment.
4. Then select More Options.
5. At the top, you'll see the installed add-ins, where you can choose the one you want to open.

Keywords

Appointment; Visit; Add-in; Server Side; Relationship; Contact; C4C; SSI , KBA , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications 2408