Symptom
When attempting to import an Account, the user encounters the error message: "Business Partner with ID already exists." However, upon searching in Accounts, no existing Account with this ID is found.
Environment
- SAP Sales Cloud Version 2
- SAP Sales and Service Cloud Version 2
Reproducing the Issue
- Navigate to User Menu > All Settings.
- Go to Data Import.
- Select Import > Create > Account.
- Choose Individual Entities.
- Select Simulation Mode and Excel option.
- Upload the file Excel file..
- Review the task result and see the error message: "Business Partner with ID already exists.".
- Search for an existing Account with that ID and find no matches.
- Check the Contacts list and find that a contact with that ID already exists.
Cause
In the system, Business Partner refers to Accounts, Contacts, and Individual Customers. IDs must be unique across all these entities. Since a contact with that ID already exists, the system prevents the creation of an Account with the same ID.
Resolution
To resolve this issue, assign a different, unique ID to the new Account before importing.
Keywords
Error, Business Partner, Import, Account, Contact, Individual Customer, Sales Cloud Version 2, CNS , KBA , CEC-CRM-ACC , Account for SAP Sales/Service Cloud , CEC-CRM-IND , Individual Customer for SAP Sales/Service Clou , CEC-CRM-CON , Contact for SAP Sales/Service Cloud , CEC-CRM-IMX , Data Import/Export for SAP Sales/Service Cloud , Problem
SAP Knowledge Base Article - Public