SAP Knowledge Base Article - Public

3523634 - Data Change Insight and Scheduled a Publications based on BW live tunnel connection are failing in SAP Analytics Cloud (SAC)

Symptom

  • There are several instances where scheduling of Data Change Insight Subscriptions and Scheduled Publications are failing.
  • In the Calendar details the following exceptions can be seen:
    Generation Status
    FailedInvalid entry
    Couldn't fetch artifact from story exporter service
     
    Info: You weren't logged on to the remote data source automatically. Please ask your administrator to verify the SAML Single Sign-On configuration for connection <connectionname>.
    Delivery Status
    FailedInvalid entry
    The publication could not be delivered because the publication generation was unsuccessful.


Environment

  • SAP Analytics Cloud (Enterprise)
  • SAP BW live connection with tunnel type

Reproducing the Issue

  1. Create model based on a live BW Connection BW with SAML Authentication type.
  2. Choose Query.
  3. Create story on top of model.
  4. Change story details.
  5. Enabled Data change insights subscribe to data change insights.
  6. In the Calendar the instance will be in failed status.
    (the same applied with Scheduled Publications)

Cause

  • There is an issue with SAML assertion created from the LCS service, as it's not in synch with what is expected on the Data sources end.
  • In the ljs_trace for SAP Cloud Connector the following entries can be seen:

Timestamp #DEBUG#com.sap.scc.security#tunnel-client-129-2#          #Generating X.509 certificate for authentication to backend
Timestamp #DEBUG#com.sap.scc.security#tunnel-client-129-2#          #Requesting token for principal with name XYZUSER
Timestamp 0#DEBUG#com.sap.scc.security#tunnel-client-129-2#          #Condition "true" fits to principal 'XYZUSER', return CN=${email}
Timestamp #DEBUG#com.sap.scc.security#tunnel-client-129-2#          #Generated X.509 certificate with subject CN=XYZUSER@this-default-was-not-configured.invalid

Timestamp #DEBUG#com.sap.scc.security#tunnel-client-129-2#          #Using cached X.509 certificate with subject CN=XYZUSER@this-default-was-not-configured.invalid
Timestamp #DEBUG#com.sap.core.connectivity.spi.processing.AbstractProtocolProcessor#tunnel-client-129-2#0x0496abd9#Successfully opened backend connection [id: 0xfbfbbcc6, L:/10.13.0.173:26394 - R:xyzserver101.hec.mycompany/10.13.0.46:44300]

Timestamp #DEBUG#com.sap.core.connectivity.tunnel.client.sso.cf.JWTValidator#tunnel-client-129-3#0x95cc9ff3#Decoded JWT with claims: {"sub":"56b5cf6c-5c60-4278-902f-c581a52e95de","xs.user.attributes":{},"user_name":"XYZUSER","origin":"9d0fcc0e-8c59-411c-bbe8-f2f82ca61b7f","iss":"http://mycompany.localhost:8080/uaa/oauth/token","xs.system.attributes":{"xs.rolecollections":[]},"given_name":"XYZUSER","client_id":"sb-identity-service-sac-saceu10!t3650","aud":["openid","sb-identity-service-sac-xyzu!t3650"],"ext_attr":{"enhancer":"XSUAA","subaccountid":"b77e917b-e201-42fa-8972-e076cf29dd5b","zdn":"mycompany"},"zid":"b77e917b-e201-42fa-8972-e076cf29dd5b","grant_type":"urn:ietf:params:oauth:grant-type:saml2-bearer","user_id":"56b5cf6c-5c60-4278-902f-c581a52e95de","azp":"sb-identity-service-sac-saceu10!t3650","scope":["openid"],"cnf":{"x5t#S256":"Od-peiHwhcMVR3_nqLBxoogw3cY1mF_7R8AZQ5WX-pA"},"exp":1727125538,"family_name":"this-default-was-not-configured.invalid","iat":1727082338,"jti":"33c3d978ec9e46bdbd18d9c0fbef5cfe","email":"XYZUSER@this-default-was-not-configured.invalid","rev_sig":"246a1d77","cid":"sb-identity-service-sac-xyzu!t3650"} 

Resolution

  • The issue can occur due to to inconsistencies in the user attributes used across the three layers:
    • SAP Cloud Connector
    • Identity Provider (IDP)
    • SAP BW
  • Following this guide,please verify the user/assertion attribute in the Cloud Connector.
  • For guidance on the BW side: Setting Up SSO Between SAP Analytics Cloud and BW.
  • Regarding the IDP, the process may vary depending on the specific provider, but it should be relatively straightforward to check which user attribute is being used.
  • If errors are continued to be experienced even after reviewing these resources and implementing the necessary changes,please reach out to SAC Product Support by creating an incident on component LOD-ANA-LDC-HAN.

See Also

Keywords

SAML Assertion, BW Live Connection, Data Change Insight, Scheduled Publication , KBA , LOD-ANA-SCH , SAC Story Scheduling and Publication , LOD-ANA-LDC-HAN , SAC Live Data Connection HANA , Problem

Product

SAP Analytics Cloud 1.0