SAP Knowledge Base Article - Public

3523781 - Unable to Set Filter on Case ID Field in Analytics for SAP Sales/Service Cloud V2

Symptom

You are trying to set a filter on the Case ID field, but only the description in the Case ID field can be filtered, not the ID itself. 

The expectation is to filter on the ID of a particular case.

Environment

SAP Sales Cloud and SAP Service Cloud Version 2

Reproducing the Issue

  1. Create a story with the data model 'Case'.
  2. Add a table.
  3. Add 'case id' as a filter.
  4. Attempt to filter on ID.

Cause

Only "Description" is selected for the search.

Resolution

  1. Navigate to the Builder tab.
  2. Add the filter Display ID.
  3. Click on the arrow beside the magnifying glass.
  4. In the drop-down menu, choose "ID and Description".
  5. Search for the desired ID.

See Also

Keywords

Case ID, filter, description, ID, Analytics for SAP Sales/Service Cloud, Builder tab, Display ID, magnifying glass, ID and Description, search. , KBA , CEC-CRM-ANA , Analytics for SAP Sales/Service Cloud , How To

Product

SAP Sales Cloud and SAP Service Cloud Version 2 all versions