Symptom
You have created a report to capture users' login and logoff times based on "User Logon Activity [COD_USER_LOGON_ANA]" standard data source but it's showing inaccurate data.
Specifically, the "Duration" column displays not assigned(#) values and "Logoff Time" column displays 00:00 in some records.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Navigate to Business Analytics work center.
- Go to Design Reports view.
- Open the report "ABC". (Where "ABC" is the desired/affected report)
- Run.
- Check the data for "Duration" and "Logoff Time" column.
Cause
The logoff timestamp in the User Logon Activity only gets updated when the user clicks on logoff on the UI. If the logoff timestamp is not updated, the system tries to estimate it based on the user's last activity and a default period of inactivity (4 hours). However, this estimated data may not be accurate for all scenarios.
Resolution
The system's current behavior is as designed. If a different behavior is desired or improvements are suggested, it is recommended to submit an improvement Request on the SAP Customer Influence site: https://influence.sap.com
See Also
Refer to SAP KBA 2734473 - User Logon Activity Report Shows "#" Instead of the Users for additional information (https://me.sap.com/notes/2734473)
Keywords
User Login Activity, inaccurate report, logoff timestamp, estimated logoff time, Improvement Request, SAP Customer Influence, Business Analytics, Design Reports, User Logon Activity, LOD-CRM-APM. , KBA , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , Problem