Symptom
- On October 1st, 2024, customers hosted on multiple data centers experienced service degradation while using Employee Central-related User Interface (UI) transactions. Customers were unable to terminate employees as the system was continuously loading after selecting the termination date. This blocked users from completing the termination process and also affected other workflows, including but not limited to Hiring or updating Employment, where onChange rules were involved.
Environment
SAP SuccessFactors Employee Central > Employment Lifecycle > Hire, Rehire, and Termination
Reproducing the Issue
- Replication for Termination
- Navigate to the profile of the employee to be terminated.
- Select the 'Actions' menu > Select 'Terminate'.
- Enter a value for one of the termination fields.
- The system continues to load indefinitely.
- Replicating for Comp Info/Job Info
- Navigate to the profile of the employee to change jobInfo/compInfo
- Select the action menu and select "Change Job Info and compInfo" or select edit on Job Info or comp info portlet
- Select any field and the system continues to load indefinitely
- Replicating for Add New hire / hire user from Manage pending hire
- Go to Add new employee or hire from user manage pending hire
- Screen load indefinably by selecting any field on Add new employee page
Cause
Root Cause Analysis
- The root cause of this incident was linked to a code patch that was released on October 1st, 2024, to address an error in updating job information. While the patch solved that problem, it introduced a regression issue in the termination process due to an interaction between submitOnFieldChange and the onChange rule. This regression issue only surfaced in the environments on 1H 2024 version, as an accessibility fix in version 2H 2024 masked the error during testing.
Resolution
- The issue was permanently resolved on October 2nd, 2024, by deploying an emergency code where our teams reverted the changes in the affected environments, ensuring that all termination processes resumed smoothly, and other affected functionalities were restored.
- If you come across similar issue, please report the same via support ticket for further analysis.
Workaround suggested during the issue:
Please add the data via import to update user data.
In case you are working with workflows, please consider enabling the Role Based Permission that allows workflows to be triggered when importing data (Enable Workflows for Selected Entities). Reference documentation: Role-Based Permissions for Employee Data Import.
See Also
- 3290498 - How to perform a Hire Date Correction mass import - Employee Central
- 2511979 - Employee Central: How Do I Terminate Employees
- 2494885 - Correct or Update Pay Component Recurring or Pay Component Non Recurring Information record via Import in Full Purge or Incremental Load
- 2317955 - Correct or Remove Job Information record via Import in Full Purge mode
- 2489526 - Correct or Update Job Relationships Information record via Import in Full Purge mode
Keywords
SAP SuccessFactors, Employee Central, Termination, Loading Issue, Termination Date, freezing, frozen, stuck, onchange, hang, screen, freeze, PTCH-44907, WEF-159869 , KBA , LOD-SF-EC-TER , Termination Details , LOD-SF-EC , Employee Central , LOD-SF-EC-JOB , Job Information , LOD-SF-EC-HIR , Hire & Rehire Wizards , LOD-SF-EC-CMP , Compensation Information & One-Time Bonus , Known Error