Symptom
Images appear cut-off in the Enhanced Search. It is not specific to any particular image or item.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Access BizX >
- Click on the 'View My Learning' tile >
- Enable the New Learning Experience toggle >
- Enter a search term in the 'Search for Learning' search bar >
- The item will appear with its thumbnail image cut-off.
Cause
The root cause of the issue is some inconsistencies in how images are rendered due to various User Experience (UX) patterns that have evolved over time. Initially, in Course home, customers were guided to upload images with a 1X1 ratio. However, with the introduction of new cards as part of the Integrated Learning Experience (ILX), this evolved into a 16X9 ratio. This is not a coding issue from the web side.
Resolution
An enhancement story has been created by the Engineering team for better user experience. The enhancement aims to reduce the 16:9 ratio to the current 1:1 frame, meaning the image size will be proportionally reduced to fit into the 1:1 part. The enhancement is planned to be released in the b2411 Learning system version.
For additional details, refer to the Product Release & Road Map Information.
See Also
Keywords
lms, learning, sf, successfactors, image, rendering, cut-off, images, library, UX, patterns, 1X1, ratio, 16X9, ILX, new, cards , KBA , LOD-SF-LMS-ILX , Integrated Learning Experience , LOD-SF-LMS , Learning Management System , LOD-SF-LMS-CAT , Catalog , Problem