Symptom
- The postal code length for a country in the SAP Sales Cloud tenant is defined with a number that does not comply with current country standards.
- This issue may leads to issues, such as errors during replication from S/4, where the country settings are maintained differently.
Environment
- SAP Cloud for Customer core applications
- SAP Sales Cloud
Reproducing the Issue
- Navigate to the Business Configuration in the SAP Sales Cloud.
- Open the activity "Countries/Regions".
- Check the settings for the related country, specifically the postal code length.
Cause
- The postal code length configuration is flexible and not hard-coded.
- Postal codes need to be adapted according to current valid country standards on customer side.
Resolution
- The postal code length can be updated via the Business Configuration activity in the SAP Sales Cloud tenant.
- Open the activity "Countries/Regions".
- Update the postal code length for the country.
- Save the changes.
Note:
- Documents that were created before the postal code configuration change are not automatically updated.
- New data records that are created after the update follow the new length and the corresponding validations.
- If an existing postal code for an address is changed, the new length and its validation are also adopted.
Keywords
SAP Cloud for Customer, SAP Sales Cloud, postal code length, Vietnam, legal change, SAP Note 1164216, update, Business Configuration, Countries/Regions, replication, S/4 to C4C, postcode , KBA , AP-RC-CTY , Countries , Problem
Product
SAP Cloud for Customer core applications all versions