SAP Knowledge Base Article - Public

3524695 - Unable to Activate From Business Rules Determination Step for Custom Party Role in Standard and Custom Party Schemas for Cases

Symptom

You notice that, after adding a custom party role to a standard or custom party schema for cases, the determination step From Business Rules is grayed out and cannot be set as Active.

Environment

SAP Service Cloud Version 2.

Reproducing the Issue

  1. Logon to your SAP Service Cloud Version 2 environment.
  2. Click on the User Menu.
  3. Click Settings.
  4. Navigate to All Settings.
  5. Click Party Schema under Cases.
  6. Select any standard or a custom party schema.
  7. Click on the Edit (pencil) button.
  8. Select any custom party role.
  9. Click Show Determination Steps.
  10. See it is not possible to set the determination From Business Rules as active.

Cause

Currently, the From Business Rules determination step will be executed taking into consideration the Case Routing to Employee or Case Routing to Team rules, which by standard only works to determine either the employee party role as a case processor or the service and support team respectively.

Resolution

This is the system designed behavior.

Keywords

Case, Cases, Party, Party Role, Custom Party, Custom Party Role, Custom Party Schema, Schema, Party Schema, Determination, Determination Step, Step, Unable, Activate, Active, SAP Service Cloud Version 2, Version 2, V2, From Business Rules, Rules, Business Rules, Grayed Out, , KBA , CEC-CRM-CAS , Case Management for SAP Sales/Service Cloud , How To

Product

SAP Sales Cloud and SAP Service Cloud Version 2 all versions ; SAP Service Cloud Version 2 all versions