SAP Knowledge Base Article - Public

3525058 - You Need to Remove the External ID Mapping for Business Partner

Symptom

You would like to delete the external ID of a business partner that is integrated with an external system. You need to know the procedure to delete the external ID from the system.

Environment

  • SAP Sales Cloud Version 2
  • SAP Sales and Service Cloud Version 2

Reproducing the Issue

  1. Open the navigation menu.
  2. Select Accounts view.
  3. In the Accounts view, locate and open the desired account.
  4. Go to Additional Identifiers tab.
  5. See the External ID under the External IDs for Integration section.
  6. Note that the user is not able to remove the External ID.

Cause

The external ID is stored as part of the business partner's data, which includes subnode entities that cannot be directly deleted through the system's interface. This requires a specific export and import process to mark these subnodes entities for deletion.

Resolution

  1. Open Settings > All Settings.
  2. Go to Import and Export Data.
  3. Click Export and select the entity (e.g., Accounts).
  4. Ensure Complete Entity is selected.
  5. Apply a filter, then click Export Data.
  6. Download and extract the file.
  7. Open the External ID Excel file.
  8. Add a "to_be_deleted" column and set "TRUE" for the relevant rows.
  9. Save and compress the files into a ZIP.
  10. Go back to Import and Export Data, click Import, and select Update.
  11. Select the entity and ensure Complete Entity is selected.
  12. Upload the ZIP file and click Import Data.

See Also

Set Up Guide for SAP Sales Cloud Version 2 -> Update Data Using Import

Keywords

External ID, Business Partner, Remove, Delete, to_be_deleted, Accounts, CNS, Sales Cloud Version 2, Import, Export, Update , KBA , CEC-CRM-ACC , Account for SAP Sales/Service Cloud , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0