SAP Knowledge Base Article - Public

3525450 - Developer console traces

Symptom

  • When performing any sort of troubleshooting, Developer Console traces are limited. It disallows the download and possibility to expand traces to verify, showing an alert message
  • Need more traces to troubleshoot with Developer Console.

Environment

SAP CPQ

Reproducing the Issue

  1. Perform any action that exceeds number of traces in developer console (since 2411 release, default is set to 100k)
  2. "The number of traces captured for the selected action exceeds the limit. In order for the trace to be conclusive and visible, please contact the SAP CPQ support team to expand the maximum number of traces per action." alert message is shown and Download Icon and Expand capability are blocked.

Cause

Since 2408 release, the Developer Console does not allow to download or visualize the traces if it passes the limit, reason for that is to avoid wrong conclusions.

Resolution

It is necessary to engage SAP Sales Cloud CPQ Support Team (CEC-SAL-CPQ) in order to request increase in number of traces.

Support Team can increase the traces to 250k, for 2 weeks, if this is not enough, it is possible to increase to 500k for 1 week.

Keywords

Developer Console, Troubleshoot, Traces, Maximum Number, Service Request, CPQ , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Bug Filed

Product

SAP CPQ 2024