SAP Knowledge Base Article - Public

3525464 - <BankStatement> more than 5 digits is not accepted by API BankStatementPost_In

Symptom

Trying to post bank statement via API BankStatementPost_In. <BankStatement> line has more than 5 digits. It is not accepted by the system and the upload ends with error: "Data loss occurred when converting &".

Same error is not coming in Manage Bank Statements App during manual upload.

Environment

SAP S/4HANA Public Cloud

Reproducing the Issue

  1. Post bank statement via API BankStatementPost_In
  2. To <BankStatement> line enter bank statement number more than 5 digits, such as 20241004. 
  3. Posting fails with error "Data loss occurred when converting 20241004".

Cause

The number of digits for bank statements were extended from five to nine digits, but this is not supported by all applications yet.

The Bank Statement Number is an ascending sequential number. Additions as date or time stamps will lead to problems with processing electronic Banks Statements when an ascending sequential number is no longer guaranteed. Bank statement numbers are restricted to five digits for BankStatementPost_In and therefore posting a bank statement with API is only supported for (up to) five digits.

Resolution

As a workaround use SAP Multi-Bank Connectivity which supports bank statement numbers up to 18 digits. Or upload bank statements via Manage Incoming Payment Files App manually.

See Also

Bank Statement - Post

The Validation Logic of End-of-Day Bank Statements

Keywords

bank statement, BankStatementPost_In, BankStatement, digit, data loss, 5 digit, API, ascending, sequential number. , KBA , FI-BL-PT-BA-2CL , bank statement (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions