SAP Knowledge Base Article - Public

3526068 - Error when editing job application: PATCH "Profile Information" update - Recruiting Management

Symptom

When a user is trying to edit a candidate's job application in the Redesigned Candidate Workbench, they are getting an error:

InternalMessage=Failed to PATCH "Profile Information" update.
errorMessage=Bad request
name=Error
code=BadRequest

Environment

SAP SuccessFactors Recruiting Management

Cause

  1. There is a required field that is configured in both the job application and candidate profile templates, however it's given read-only permission for the job application and therefore cannot be modified.
  2. A required Picklist field cannot be edited because the Picklist ID linked to the field contains special characters.
  3. A custom field was saved as reportable but "Synchronize Existing Data" was not selected afterwards.
  4. The field is included in sm-mapping and the recruiting user has no permission to edit the field in EC Data Model.

Resolution

Solution for Cause 1:

In the Redesigned Candidate Workbench if a custom field is configured in both the Application Template and Candidate Profile Template, then this field should be visible in Application portlet and will only consider the Application field's permissions given to the operators.

Due to that, if a field is set as required in one of the templates and is not given write permission to edit the field, it will throw the error.

There are 3 ways to overcome this behavior:

  1. Give write permission to these fields in the Job Application
    Then update these fields values in Application template and after that user can update the profile portlet data.
  2. Remove the field configuration from the Job Application Template
    Then it will start appearing in Profile portlet, and user can update the profile data successfully.
  3. Make the field not required

This was already documented in the implementation guide: Visibility of Standard and Custom Field in Portlets

Solution for Cause 2:

To edit the Picklist field, remove any special characters from the Picklist ID in both the Picklist Center and the Job Application template.

For further instructions, refer to the KBA 3538727 - Unable to edit a Picklist field using Latest Applicant Workbench - Recruiting Management.

Solution for Cause 3:

Any time a field has been saved as custom reportable, it is required to select "Synchronize Existing Data" to ensure the changes take full effect.

Solution for Cause 4:

Scenario:

  • The field is editable for the recruiter on RCM side
  • The field is included in sm-mapping in Candidate Profile Template
  • "Revert to using Succession Data Model for permissions for SM-mapped fields" is enabled in Manage Recruiting Settings
  • In EC Data Model, the field is not editable

If the field is editable from the RCM side but not editable from the EC side, then the field will not be editable overall. 

Although metadata might mark the field as editable (recruiting user can edit the field in Redesigned Applicant Workbench), during the actual edit operation, system again check write permissions using the source userId and target userId.

If the system finds the field is not editable at that point, it will terminate the update process and throw an appropriate error message.

Note: This scenario applies to all sm-mapped fields except Email Address and Cell Phone.

Solution: Give write permission to the user in EC Data Model for that field.

See Also

User Assistance Documentation: Visibility of Standard and Custom Field in Portlets

KBA: 3538727 - Unable to edit a Picklist field using Latest Applicant Workbench - Recruiting Management

Keywords

RCM, UXR, candidate, workbench, redesigned, uxr, latest, application, profile, field, update, change, field, applicant , KBA , LOD-SF-RCM-APP-LWB , Latest applicant WorkBench , Problem

Product

SAP SuccessFactors Recruiting all versions