SAP Knowledge Base Article - Public

3526207 - Default Locale cannot be updated error message - Integration Center

Symptom

You have created an inbound integration using Integration Center and the Upsert performed by the integration fails with an error message stating, “Default Locale cannot be updated”.

Environment

  • SAP SuccessFactors HCM Suite
    • Integration Center

Reproducing the Issue

When running the Integration Center job, customer is getting the following ERROR MESSAGES:

“Http Error response code: 400 and message: Updating of the Attribute failed. Default Locale cannot be updated. Error occurred for Library id 1018. Previously set default locale is en_US”

Cause

Default Locale cannot be updated for a user which is already set in UI.

Resolution

The error Message Indicates that the default local cannot be updated.

In Error message itself it states the current default locale which is set.

While Upserting the data you need to ensure that the correct default locale set is maintained in the Input file.

You cannot update the default locale. The default locale which is already set needs to be passed in the input file. If other value rather than the default locale is passed IC job will fail with the above error message.

Pass the Default Locale which is provided in the Error Message in the Input file and re-run the IC job with the correct values. The IC job will complete the Execution without the error message.

See Also

2395445 - Default Locale | How to control the user language in SuccessFactors - SAP for Me

Keywords

Default Locale cannot be updated, Default, Locale, cannot be updated, Default Locale, ic, integration center, error handling, errors, key, record, index, value, upsert, fail, failing, not showing, SuccessFactors, success factors, 400, Updating of the Attribute failed, Http Error response code: 400 and message , KBA , LOD-SF-INT-INC-JOB , Integration Center Job , LOD-SF-INT-INC , Integration Center , Problem

Product

SAP SuccessFactors HCM Core 2405