SAP Knowledge Base Article - Public

3526257 - Absence Status Displayed as "Approved" After Withdrawal of Cancellation Workflow

Symptom

Employee cancels approved absence, and triggers a cancellation workflow. Employee then Withdraws Cancellation workflow, absence approval status reverts to Approved status.

Environment

SAP SuccessFactors Employee Central - Time Management

Reproducing the Issue

  1. Navigate to approved Absence. 
  2. Edit Absence > Cancel Time Off.
  3. Cancellation workflow is triggered for approval and Absence status changes to 'Cancellation Pending'.
  4. Navigate Pending Workflows page > Withdraw pending cancellation workflow.
  5. Check Absence approval status has now changed to 'Approved'.

Cause

This is the expected behavior when an employee tries to cancel an already approved absence. This triggers a Cancellation workflow for the user and the absence moves to the Cancellation Pending status. If the employee then withdraws the Cancellation workflow, the absence reverts to its previous status of Approved.

Resolution

  1. Understand that when an employee tries to cancel an already approved absence, this triggers a Cancellation workflow.
  2. If the employee then withdraws the Cancellation workflow, the absence reverts to its previous status of Approved.
  3. This is the expected behavior and users will receive workflow action cancelled email notifications.

See Also

2613630 - How To Set A Different Workflow For Time Off Leave Cancellation? - SAP for Me

2582461 - Cancellation Email Notification not sent after cancellation of Approved Absences - SAP for Me

Keywords

SAP SuccessFactors, Employee Central, Workflow, Approved, Withdrawn, Cancelled, Pending Workflows UI, Cancellation workflow, Pending Cancellation , KBA , LOD-SF-EC-TIM-WAN , Workflows - Alerts - Notifications , LOD-SF-EC-TIM , Time Off , LOD-SF-EC-TIM-ABS , Absence error's - Calculations, Deductions, TT&ET , Problem

Product

SAP SuccessFactors Employee Central all versions