Symptom
You try to search attendees for a Visit by using the E-mail field in Advanced Search of Add Multiple Attendees when you create a Visit, however you are not able to find some attendees.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Visit work center
- Go to the Visit work center view
- Click Create
- Click Add Multiple Attendees
- Click Advanced Search
- Put name@sap.com in the E-Mail field (Where name@sap.com is an e-mail address of an employee)
- Click Go
Result: No data is displayed.
Cause
It searches for the E-mail ID in BUSINESS_PARTNER_RELATIONSHIP contact details. It means it only searches for the main Contact e-mail of an Account to add the Account as an attendee.
Note
This is a scenario when creating a new Visit. If you search Attendees by e-mail in an existing Visit, the behaviour is different. Refer to KBA 3528565 - Unable to Search Attendees by E-Mail with Advanced Search for Add Multiple Attendees in Attendees Facet of Visit.
Resolution
This is an expected system behavior.
If the feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available.
An alternative option may be to check the corresponding SAP Customer Influence Site to submit an idea:
See Also
Keywords
advanced search, multiple attendees, visit, e-mail, email , KBA , LOD-CRM-ACT , Activities , Problem