Symptom
The "My Orders" feature is not accessible to certain users. when these users attempt to access "My Orders", they are met with a message stating "You have no orders, or you do not have permission to access this functionality".
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Login to BIZX
- Access Learning
- Click Drop Down of Activities Menu
- Click 'Orders' -> Error appears "You have no orders, or you do not have permission to access this functionality."
Cause
No orders will be displayed if there have been no orders in the last 6 months. this is currently an expected behavior of the system.
Resolution
As confirmed by Engineering team, The "My Orders" feature in the Activities menu drop down only shows orders from the past 6 months, which is the default time frame. If there are no orders within the past 6 months, none will be displayed.
[Recommendation : If you believe the "My orders" feature should display all orders OR include a filter option in a future release of the LMS, Please submit an enhancement request by referring the KBA - 2090228.]
See Also
Keywords
No order displays, You have no orders, My Orders, You do not have permission to access this functionality, You do not have permission to access orders, users unable to see orders, My Orders access issue. , KBA , LOD-SF-LMS-USR , User Entity , Problem