SAP Knowledge Base Article - Public

3527014 - Unable To Save External ID In Registered Product

Symptom

When a new Registered Product is created and an External ID is maintained, the value is not saved in the field after creation.

Environment

SAP Sales Cloud and SAP Service Cloud Version 2

Reproducing the Issue

  1. From the Navigation Menu, go to Registered Products.
  2. Click on the Create (+) button.
  3. In the Create Registered Product pop-up, enter values in all mandatory fields and populate the External ID field as well with a value.
  4. Click on Save and Open.

Notice that in detail view of newly created Registered Product, the External ID field value is empty.

Cause

This is the current designed behavior of the system. External ID is intended to be used for SAP provided standard integration between SAP systems.

Resolution

For integration with a third-party system or any other use-case, it is recommended to use an extension field to store the External ID field value.

See Also

3517470 - Extension field doesn't keep value after save

Keywords

External ID, Registered Product, Save, Empty, Blank, Extension , KBA , CEC-CRM-RPD , Registered Products for SAP Sales/Service Cloud , CEC-CRM-IP , Installation Points for SAP Sales/Service Cloud , CEC-CRM-IB , Installed Base for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0