SAP Knowledge Base Article - Public

3527103 - Employee Responsible not populating automatically when selecting "Associate to Account & Contact" in Lead

Symptom

Employee Responsible is not populated when you "Associate to Account & Contact" in Lead and not select an Account in the duplicate check pane. The Employee Responsible is only populated when you select an already created Account. 

Environment

SAP Cloud for Customer 

Reproducing the Issue

  1. Go to Sales Workcenter. 
  2. Open Leads view.
  3. Open a Lead.
  4. Note that the Employee Responsible field is not populated.
  5. Click on Actions and select "Associate Account and Contact".
  6. Do not select one of the accounts on the Duplicate Check Result
  7. Click Save.  
  8. In the Lead, the Employee Responsible is not populated. 
  9. Employee Responsible will only be populated if you select an Account in the Duplicate Check. 

Cause

The Employee Responsible field is designed to populate based on specific criteria. When you select an existing Account during the Duplicate Check, the system can automatically assign the current user as the Employee Responsible because it has a clear context of which Account is being associated with the Lead. This is why you can see it populated in that scenario.

However, when you create a new Account and do not select an existing one, the system lacks the necessary context to automatically assign the Employee Responsible, as the system relies on the existing account context to make that assignment.

Resolution

To summarize, the "Qualified By" field is designed to populate automatically when there's a clear association with an existing account.  This is the current behavior of SAP Cloud for Customer. 
 
If the feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available. An alternative option may be to check the SAP Cloud for Customer Influence Site to submit an idea.

Keywords

Owner , Employee Responsible , Lead , Empty , Assigned , Appearing , Account  , KBA , LOD-CRM-LM , Lead Management , Problem

Product

SAP Cloud for Customer core applications 2408