Symptom
Employee Responsible is not populated when you "Associate to Account & Contact" in Lead and not select an Account in the duplicate check pane. The Employee Responsible is only populated when you select an already created Account.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Sales Workcenter.
- Open Leads view.
- Open a Lead.
- Note that the Employee Responsible field is not populated.
- Click on Actions and select "Associate Account and Contact".
- Do not select one of the accounts on the Duplicate Check Result
- Click Save.
- In the Lead, the Employee Responsible is not populated.
- Employee Responsible will only be populated if you select an Account in the Duplicate Check.
Cause
The Employee Responsible field is designed to populate based on specific criteria. When you select an existing Account during the Duplicate Check, the system can automatically assign the current user as the Employee Responsible because it has a clear context of which Account is being associated with the Lead. This is why you can see it populated in that scenario.
Resolution
Keywords
Owner , Employee Responsible , Lead , Empty , Assigned , Appearing , Account , KBA , LOD-CRM-LM , Lead Management , Problem